Cox Engines Forum
You are not logged in! Please login or register! Guests are limited to posting in the "General Questions (Guest Posting Allowed)" section only. Becoming a member is fast, easy and FREE!


Log in

I forgot my password

Search
 
 

Display results as :
 


Rechercher Advanced Search

Latest topics
» How's the weather?
by KariFS Today at 2:59 am

» Videos not loading
by Marleysky Yesterday at 11:04 pm

» Shark XV Video
by Tee Bee Yesterday at 9:18 pm

» *For Sale* NIB Dick Mathis "Pinto"
by Ken Cook Yesterday at 5:12 pm

» Select Hobbies.
by 66 Malibu Yesterday at 4:21 pm

» 1939 Plymouth truck.. with radial engine installed
by rsv1cox Yesterday at 12:19 pm

» Cox Odyssey Spare parts and more ...
by MauricioB Yesterday at 11:43 am

» Differences between Texaco and other cox back plates
by NEW222 Yesterday at 11:10 am

» R/C dumb. Could use some help
by getback Yesterday at 8:22 am

» Tee Dee Head vs Medallion Head
by getback Thu Dec 14, 2017 8:59 am

Cox Engine of The Month
December-2017
1/2A Nut's

"Chrome Moly TD .020 RC"



PAST WINNERS
Speed Contest 2018
CEF Traveling Engine

Gallery


Win This Engine!
The Traveling Prop
World of Aviation

Glow head issue?

View previous topic View next topic Go down

Glow head issue?

Post  Cribbs74 on Fri Dec 02, 2011 9:46 am

Guys,

I have a prob with one of my pee wee's it runs real well when the battery clip is attached but, when I pull the clip it starts to burble and it's tough to keep it running. If I re-attach the clip it takes off again and runs fine. The glow head looks almost new and glows bright when on the battery. Any Ideas?
avatar
Cribbs74
Moderator

Trusted Seller
Posts : 9568
Join date : 2011-10-24
Age : 43
Location : Tuttle, OK

View user profile

Back to top Go down

Re: Glow head issue?

Post  PV Pilot on Fri Dec 02, 2011 10:37 am

That's usually a really rich condition for the first check.

Does it stay lit if you leave the battery attached until it warms up?
avatar
PV Pilot
High Tech Balsa Basher
High Tech Balsa Basher

Posts : 1832
Join date : 2011-08-11
Age : 51
Location : The ragged end of the Universe.

View user profile

Back to top Go down

Re: Glow head issue?

Post  Cribbs74 on Fri Dec 02, 2011 10:54 am

Perhaps more info would help. Usual start procedure followed, when it starts it's rich needle adjusted until it leans and smooths out. Pull the clip and then crackling and burbling etc. It's kind of like the glow plug won't stay hot. If I re attach the clip it goes back to running like normal.

With the glow head off the engine with the battery connected it glows red all day long.
avatar
Cribbs74
Moderator

Trusted Seller
Posts : 9568
Join date : 2011-10-24
Age : 43
Location : Tuttle, OK

View user profile

Back to top Go down

Re: Glow head issue?

Post  RknRusty on Fri Dec 02, 2011 10:56 am

Methanol deficient fuel? I doubt it, not if your other engines run okay. Something has coated the platinum so the methanol cannot come in contact with it. Have you ever added an anti-foam agent to the fuel with this engine? Like a drop of Armour All. This is a strange one.

Try washing it with some acetone.

_________________
Don't Panic!
...and never Ever think about how good you are at something...
while you're doing it!


My Hot Rock & Blues Playlist
avatar
RknRusty
Moderator

Posts : 10445
Join date : 2011-08-10
Age : 61
Location : South Carolina, USA

View user profile

Back to top Go down

Re: Glow head issue?

Post  SuperDave on Fri Dec 02, 2011 11:10 am

I too suspect contamination of the glo element. A cleaning with acetone as suggested may help.

If it doesn't try a known good replacement glo head.
avatar
SuperDave
Top Poster
Top Poster

Posts : 3552
Join date : 2011-08-13
Location : Washington (state)

View user profile

Back to top Go down

Re: Glow head issue?

Post  microflitedude on Fri Dec 02, 2011 11:26 am

Is the coil in good shape? If it is deformed or out of center the engine will not run well.

The smaller the engine, the more sensitive.
avatar
microflitedude
Top Poster
Top Poster

Trusted Seller
I Support My Forum

Posts : 3417
Join date : 2011-08-17
Age : 19
Location : Columbia, SC

View user profile https://www.facebook.com/MiniCub?fref=ts

Back to top Go down

Re: Glow head issue?

Post  Cribbs74 on Fri Dec 02, 2011 12:30 pm

I will try cleaning it and ensure it is centered. I also will post back with results.
avatar
Cribbs74
Moderator

Trusted Seller
Posts : 9568
Join date : 2011-10-24
Age : 43
Location : Tuttle, OK

View user profile

Back to top Go down

Re: Glow head issue?

Post  Cribbs74 on Fri Dec 02, 2011 12:33 pm

RknRusty wrote:Methanol deficient fuel? I doubt it, not if your other engines run okay. Something has coated the platinum so the methanol cannot come in contact with it. Have you ever added an anti-foam agent to the fuel with this engine? Like a drop of Armour All. This is a strange one.

Try washing it with some acetone.

I have not added a foaming agent. Using Sig champion fuel. Works fine in all engines but this one. By adding an agent are you saying to do that or not do that.
avatar
Cribbs74
Moderator

Trusted Seller
Posts : 9568
Join date : 2011-10-24
Age : 43
Location : Tuttle, OK

View user profile

Back to top Go down

Re: Glow head issue?

Post  Admin on Fri Dec 02, 2011 12:54 pm

Try a new head if you have one. If it does the same thing, there could be something up with your fuel. Is the fuel old? Did you notice any condensation on the inside of the bottle? Did you leave the cap off for some extended amount of time?
avatar
Admin
Administrator

Posts : 4441
Join date : 2010-07-27
Location : Roseville/St.Paul Minnesota, USA

View user profile http://sites.google.com/site/coxenginecollection/

Back to top Go down

Re: Glow head issue?

Post  PV Pilot on Fri Dec 02, 2011 1:22 pm

cribbs74 wrote:I will try cleaning it and ensure it is centered. I also will post back with results.

I would just try a soak, no toothbrushing obviously.

Back to my old standby. I have used Eagle 1 etching formula mag wheel cleaner and the reason for posting that is because I recently brought a old cruddy standard short Fox plug back from the dead. There was severe crud packed in around the coil Hooked it up intially to my glow driver and it wouldn't do anything, so I tried a soak and a few shake-outs with the Eagle 1 stuff and it worked, The plug lit up real nice and pulled about 3-4 amps at 1.5 volts. Hydrophluoric acid in there, so be carefull around soft painted surfaces and finger cuts,,better yet, wear some painters latex gloves. rinse it off well with just tap water, wipe the alum dust off with a towel

Auto parts store for that Eagle 1.
avatar
PV Pilot
High Tech Balsa Basher
High Tech Balsa Basher

Posts : 1832
Join date : 2011-08-11
Age : 51
Location : The ragged end of the Universe.

View user profile

Back to top Go down

Re: Glow head issue?

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum