Cox Engines Forum
You are not logged in! Please login or register.

Logged in members see NO ADVERTISEMENTS!


I've had a bad day.... Cox_ba12




I've had a bad day.... Pixel

Log in

I forgot my password

Search
 
 

Display results as :
 


Rechercher Advanced Search

Latest topics
» Scientific Gulfhawk
by Mike1484 Today at 7:20 am

» Roddie tears-down his recent bench-run engine
by roddie Yesterday at 11:22 pm

» Gut instinct
by Onelife Yesterday at 5:39 pm

» Cox Ryan ST 2.0
by rdw777 Yesterday at 4:23 pm

» My Cox .049 reedy with a Galbreath head and Nelson plug
by F4D Phantom II Yesterday at 11:03 am

» audio-tach anyone?
by roddie Mon May 20, 2024 9:09 pm

» Jim Walkers FireBee - This is going to be fun
by rsv1cox Mon May 20, 2024 8:16 pm

» Nostalgia alert, my 1959 Corvette revisited
by crankbndr Mon May 20, 2024 5:15 pm

» Prayers for my Wife Please
by fit90 Mon May 20, 2024 7:34 am

» Prop Rod - resto to a runner
by getback Mon May 20, 2024 6:19 am

» WenMac 049 - Glow Plug & Head Gasket replacements?
by Ken Cook Sun May 19, 2024 7:50 pm

» 12 string guitar suggestions
by akjgardner Sun May 19, 2024 7:08 pm

Cox Engine of The Month
May-2024
1/2A Nut's

"Cox Tee Dee .051 RC Marine"



PAST WINNERS
CEF Traveling Engine

Win This Engine!
Gallery


I've had a bad day.... Empty
Live on Patrol


I've had a bad day....

Go down

I've had a bad day.... Empty I've had a bad day....

Post  WingingIt74 Sun Nov 04, 2012 3:00 pm

I crashed today:

• Electifly Gee Bee, actually it tore the engine mount off on the ground DAMMIT!
• Cox Top Gun... It flies different with the engine running, I got two laps before I flew it into the concrete. I hope I can glue it, but it will need a new prop and spinner DAMMIT!
• Crashed into Jeremy's Millinum SSX on landing and broke his wing, my Parkzone Super Cub is fine DAMMIT!

I think I'm done flying today.

WingingIt74
WingingIt74
Top Poster
Top Poster

Posts : 3189
Join date : 2011-08-11
Age : 49
Location : Waterloo, IL

https://www.facebook.com/wingingit74/

Back to top Go down

I've had a bad day.... Empty Re: I've had a bad day....

Post  Kim Sun Nov 04, 2012 3:35 pm

"Some Days are Diamonds...Some Days are Stone"

....and some days are a jagged, eye-piercing shard of plate glass....

Sorry to hear dude! I wondered where you were as I perused the crowded tables in Columbia !!!
Kim
Kim
Top Poster
Top Poster

2022 Supporter

2023 Supporter

2024 Supporter

Posts : 8538
Join date : 2011-09-06
Location : South East Missouri

Back to top Go down

I've had a bad day.... Empty Re: I've had a bad day....

Post  Cribbs74 Sun Nov 04, 2012 3:59 pm

Sorry man, sounds like my weekend.......

If it were me I would build something out of Balsa that wouldn't hurt so bad if you crashed it. On the other hand.... good on you for having the nads to fly your stuff.

Things will look better tomorrow. Hopefully Smile
Cribbs74
Cribbs74
Moderator

2022 Supporter

2023 Supporter

2024 Supporter

Posts : 11899
Join date : 2011-10-24
Age : 50
Location : Tuttle, OK

Back to top Go down

I've had a bad day.... Empty Re: I've had a bad day....

Post  WingingIt74 Sun Nov 04, 2012 4:28 pm

Top Gun broke almost identical to what I remember as a kid...
WingingIt74
WingingIt74
Top Poster
Top Poster

Posts : 3189
Join date : 2011-08-11
Age : 49
Location : Waterloo, IL

https://www.facebook.com/wingingit74/

Back to top Go down

I've had a bad day.... Empty Re: I've had a bad day....

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum